轶哥

妄图改变世界的全栈程序员。

ubuntu 20.04 安装 pip2
  •   更新:2021-08-09 00:21:45
  •   首发:2021-03-14 17:34:03
  •   教程
  •   7696

在ubuntu 20.04 LTS版本中,可以通过sudo apt install python安装python2,但是无法通过sudo apt install python-pip安装pip2,提示E: Unable to locate package python-pip

无法找到python-pip安装包的原因是,Python 2.7的支持周期已于2020年1月1日结束。因为不再维护Python 2.7,pip 21.0已于2021年1月停止对Python 2.7的支持。

如果通过pypa.io的默认get-pip.py脚本进行安装,也将遇到This script does not work on Python 2.7 The minimum supported Python version is 3.6.提示。

正确的安装姿势

sudo apt install wget python-is-python2 # 安装wget和python2
wget https://bootstrap.pypa.io/pip/2.7/get-pip.py
python get-pip.py

image.png

重启终端后,即可执行pippip2命令。

此安装方法同样适用于WSL2。

Ubuntu 20.04 LTS安装python2和python3以及对应pip

复制下面的命令,可快速完成python2和python3以及对应pip的安装。

sudo apt install wget python python3 python3-pip python-ply python3-ply -y
wget https://bootstrap.pypa.io/pip/2.7/get-pip.py
python get-pip.py

image.png

记得重启终端。

打赏
交流区

暂无内容

尚未登陆
发布
  上一篇 (CentOS8卸载podman安装docker)
下一篇 (SR300 F200 开启 Windows Hello 人脸登录)  

评论回复提醒